解决LNMP环境下WP升级或安装插件主题要输入FTP的方法

LNMP.jpg

问题描述:使用军哥LNMP1.4一键安装包搭建的服务器环境,运行wordpress在后台升级WP版本更新、安装或更新WP插件及主题时,提示和要求输入FTP信息。

问题原因:Nginx的执行身份用户组非文件用户组。

解决方法:

1、检查wordpress网站的安装目录,如 /home/wwwroot/your_directory

2、使用SecureCRT 、putty等工具登录远程服务器(linux vps),执行命令:

chown -R www /home/wwwroot/your_directory

该命令的作用是把 /home/wwwroot/your_directory 下的所有文件的用户组改为 www

修改原因:Ngingx的默认用户组一般是 www ,授予www对文件夹的权限即可解决问题;如果不是此用户组,可以在配置文件 nginx.conf 中查看。

猜您喜欢

发表评论

icon_mrgreen.gificon_neutral.gificon_twisted.gificon_arrow.gificon_eek.gificon_smile.gificon_confused.gificon_cool.gificon_evil.gificon_biggrin.gificon_idea.gificon_redface.gificon_razz.gificon_rolleyes.gificon_wink.gificon_cry.gificon_surprised.gificon_lol.gificon_mad.gificon_sad.gificon_exclaim.gificon_question.gif